在线检测未来函数

通达信永不套牢无背主图指标公式

来源:Internet,编辑:太阳城娱乐,2019-04-23

M1:=3;
M2:=5;
M3:=8;
M4:=13;
M5:=21;
M6:=34;
M7:=55;
M8:=89;
M9:=144;
M10:=233;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
K:=BARSLAST(CURRBARSCOUNT=60);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0)),NODRAW;
DDA:=CONST(IF(ISLASTBAR=1,LLV(L,K),0)),NODRAW;
KJ:=GD-DDA;
一:IF(CURRBARSCOUNT<=5,DDA+KJ*0.1,DRAWNULL),COLORYELLOW,DOTLINE;
二: IF(CURRBARSCOUNT<=5,DDA+KJ*0.28,DRAWNULL),COLORYELLOW,DOTLINE;
三:IF(CURRBARSCOUNT<=5,DDA+KJ*0.41,DRAWNULL),COLORYELLOW,DOTLINE;
四:IF(CURRBARSCOUNT<=5,DDA+KJ*0.54,DRAWNULL),COLORYELLOW,DOTLINE;
五:IF(CURRBARSCOUNT<=5,DDA+KJ*0.62,DRAWNULL),COLORYELLOW,DOTLINE;
六:IF(CURRBARSCOUNT<=5,DDA+KJ*0.74,DRAWNULL),COLORYELLOW,DOTLINE;
七:IF(CURRBARSCOUNT<=5,DDA+KJ*0.88,DRAWNULL),COLORYELLOW,DOTLINE;
八:IF(CURRBARSCOUNT<=5,DDA+KJ*1,DRAWNULL),COLORYELLOW,DOTLINE;
DRAWTEXT(CURRBARSCOUNT=1,一,' 一线'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,二,' 二线'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,三,' 三线'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,四,' 四线'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,五,' 五线'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,六,' 六线'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,七,' 七线'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=1,八,' 八线'),COLOR00FFFF;
跟A7:=C-REF(C,1);
跟A8:=100*EMA(EMA(跟A7,6),6)/EMA(EMA(ABS(跟A7),6),6);
买:=LLV(跟A8,2)=LLV(跟A8,7) AND COUNT(跟A8<0,2) AND CROSS(跟A8,MA(跟A8,2));
跟庄买进:DRAWTEXT(FILTER(买=1,5),L*0.9999,'∠跟庄买进')COLORMAGENTA;
TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=EMA(TA,13);
VAR8A:=REF(CLOSE,1)-REF(ATR,1);
永不套牢线:HHV(VAR8A,13), COLORCYAN;
DRAWTEXT(ISLASTBAR,永不套牢线,' 永不套牢线'), COLORWHITE;
N8:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y8:=STRCAT(CON2STR(MONTH,0),' 月 ');
R8:=STRCAT(CON2STR(DAY,0),' 日 ');
SJ8:=STRCAT(STRCAT(N8,Y8), R8);
SJ9:=STRCAT(STRCAT(N8,Y8), R8);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,1.02,0,SJ8),COLORYELLOW;
MA3:MA(CLOSE,M1);
MA5:MA(CLOSE,M2);
MA8:MA(CLOSE,M3);
MA13:MA(CLOSE,M4);
MA21:MA(CLOSE,M5);
MA34:MA(CLOSE,M6);
MA55:MA(CLOSE,M7);
MA89:MA(CLOSE,M8);
MA144:MA(CLOSE,M9);
MA233:MA(CLOSE,M10);

通达信永不套牢无背主图指标公式

 

相关文章