在线检测未来函数

通达信BBI双线主图指标公式

来源:Internet,编辑:太阳城娱乐,2019-03-20

M1:=3;
M2:=6;
M3:=12;
M4:=24;
M5:=6;
M6:=12;
M7:=24;
M8:=48;
M9:=12;
M10:=24;
M11:=48;
M12:=96;
M13:=24;
M14:=48;
M15:=96;
M16:=192;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
做多:=IF(K>D AND MACD>0 AND V>1,2,0),COLORRED;
做空:=IF(K<D AND MACD<0 AND V>1,-2,0),COLOR00FF00;
强洗:=IF(MACD>0 AND K<D AND V>1,1,0),COLOR0099FF;
弱升:=IF(MACD<0 AND K>D AND V>1,-1,0),COLORFFFF00;
STICKLINE(做多,L,H,0.5,0),COLORRED;
STICKLINE(做多 AND C>=O,C,O,3,1),COLORRED;
STICKLINE(做多 AND C<O,C,O,3,0),COLORRED;
STICKLINE(做空,L,H,0.5,0),COLOR00FF00;
STICKLINE(做空 AND C>=O,C,O,3,1),COLOR00FF00;
STICKLINE(做空 AND C<O,C,O,3,0),COLOR00FF00;
STICKLINE(强洗,L,H,0.5,0),COLOR0099FF;
STICKLINE(强洗 AND C>=O,C,O,3,1),COLOR0099FF;
STICKLINE(强洗 AND C<O,C,O,3,0),COLOR0099FF;
STICKLINE(弱升,L,H,0.5,0),COLORFFFF00;
STICKLINE(弱升 AND C>=O,C,O,3,1),COLORFFFF00;
STICKLINE(弱升 AND C<O,C,O,3,0),COLORFFFF00;
BBI:(MA(CLOSE,M1)+MA(CLOSE,M2)+MA(CLOSE,M3)+MA(CLOSE,M4))/4,LINETHICK1;
BBI2:(MA(CLOSE,M5)+MA(CLOSE,M6)+MA(CLOSE,M7)+MA(CLOSE,M8))/4,LINETHICK1;
BBI3:(MA(CLOSE,M9)+MA(CLOSE,M10)+MA(CLOSE,M11)+MA(CLOSE,M12))/4,LINETHICK1;
BBI4:(MA(CLOSE,M13)+MA(CLOSE,M14)+MA(CLOSE,M15)+MA(CLOSE,M16))/4,COLORFFFF00,LINETHICK2;
MA60:MA(C,60),COLORFF0000,LINETHICK2;
IF(MA(C,60)>=REF(MA(C,60),1),MA(C,60),DRAWNULL),COLORYELLOW,LINETHICK2;

通达信BBI双线主图指标公式

 

相关文章